<!DOCTYPE html><html lang="de" prefix="og: http://ogp.me/ns#">	
<head>
<link href="https://fonts.googleapis.com" rel="preconnect" crossorigin>
<link href="https://www.google-analytics.com" rel="preconnect" crossorigin>
<link href="https://api.permutive.com" rel="preconnect" crossorigin>
<link href="https://de.ioam.de" rel="preconnect" crossorigin>
<link href="https://script.ioam.de" rel="preconnect" crossorigin>
<link href="https://tt.onthe.io" rel="preconnect" crossorigin>
<link href="https://www.googletagmanager.com" rel="preconnect" crossorigin>
<link href="https://images.computerwoche.de" rel="preconnect" crossorigin>
<meta http-equiv="Content-type" content="text&#x2f;html&#x3b;&#x20;charset&#x3d;utf-8" />
<title>DevOps im Fokus: Heute arbeiten Entwickler bei Microsoft viel autonomer und effizienter - Microsoft</title>
<meta content="width=device-width,minimum-scale=1,maximum-scale=1,initial-scale=1" name="viewport" />
<meta content="noodp" name="robots" />
<meta content="Digitale Produkte werden in jeder Branche entscheidend, und damit auch die Effizienz der Softwarearchitekten. Microsoft hat in den vergangenen Jahren seine eigene Softwareentwicklung radikal transformiert." name="description" />
<meta content="" name="keywords" />
<meta content="" name="news_keywords" />
<meta content="DevOps im Fokus: Heute arbeiten Entwickler bei Microsoft viel autonomer und effizienter" property="og:title" name="og:title" />
<meta content="https://microsoft.cio.de/a/mso-freiheit-und-verantwortung-fuer-devops-entwickler,3652903" property="og:url" name="og:url" />
<meta content="Digitale Produkte werden in jeder Branche entscheidend, und damit auch die Effizienz der Softwarearchitekten. Microsoft hat in den vergangenen Jahren seine eigene Softwareentwicklung radikal transformiert." property="og:description" name="og:description" />
<meta content="summary_large_image" name="twitter:card" />
<meta content="https://microsoft.cio.de/a/mso-freiheit-und-verantwortung-fuer-devops-entwickler,3652903" name="twitter:url" />
<meta content="DevOps im Fokus: Heute arbeiten Entwickler bei Microsoft viel autonomer und effizienter" name="twitter:title" />
<meta content="Digitale Produkte werden in jeder Branche entscheidend, und damit auch die Effizienz der Softwarearchitekten. Microsoft hat in den vergangenen Jahren seine eigene Softwareentwicklung radikal transformiert." name="twitter:description" />
<meta content="@" name="twitter:site" />
<meta content="https://images.computerwoche.de/bdb/3261539/640x360.jpg" property="og:image" name="og:image" />
<meta content="image/jpg" property="og:image:type" name="og:image:type" />
<meta content="640" property="og:image:width" name="og:image:width" />
<meta content="360" property="og:image:height" name="og:image:height" />
<meta content="https://images.computerwoche.de/bdb/3261539/640x360.jpg" name="twitter:image" />
<meta content="Sponsored" name="outbrainsection" />
<link href="https&#x3a;&#x2f;&#x2f;microsoft.cio.de&#x2f;a&#x2f;mso-freiheit-und-verantwortung-fuer-devops-entwickler,3652903" rel="canonical"></link>
<link href="https&#x3a;&#x2f;&#x2f;microsoft.cio.de&#x2f;a&#x2f;amp&#x2f;mso-freiheit-und-verantwortung-fuer-devops-entwickler,3652903" rel="amphtml" type="text&#x2f;html"></link>
<link rel="icon" href="/favicon.ico" type="image/x-icon" sizes="48x48">
<link rel="icon" href="/favicon.png" type="image/png" sizes="256x256">
<link rel="stylesheet" href="/includes/compiled/??001_core.min.css,010_themes.onepager.min.css,015_clients.mso.min.css?v=202102031658" media="all" />
<script>
var idgStorage = new Object();
idgStorage.delayedFunctions = new Array();
String.prototype.rot13 = function(s) { return (s ? s : this).split('').map(function(_) { if (!_.match(/[A-Za-z]/)) return _; c = Math.floor(_.charCodeAt(0) / 97); k = (_.toLowerCase().charCodeAt(0) - 83) % 26 || 26; return String.fromCharCode(k + ((c == 0) ? 64 : 96));}).join('');};
idgStorage.setRot13 = function(key, value) {this[key.rot13()] = value.rot13()};
idgStorage.set = function(key, value) {this[key] = value};
idgStorage.dump = function() {console.log(this)};
idgStorage.ibw = (window.innerWidth);
idgStorage.ibh = (window.innerHeight);
idgStorage.currentStatusId = 5;
idgStorage.setRot13('raivebazrag', 'njf');
idgStorage.setRot13('pyvragFubegphg', 'zfb');
idgStorage.setRot13('vqtGurzr', 'barcntre');
idgStorage.setRot13('vzntrOnfrcngu', 'uggcf://vzntrf.pbzchgrejbpur.qr/oqo/');
idgStorage.setRot13('vzntrOnfrcnguCe','//vzntrf.pbzchgrejbpur.qr/oqo/');
idgStorage.setRot13('vijNatrobg', '');
idgStorage.setRot13('vijSenob', 'ke');
idgStorage.setRot13('tnyyrelWFBAOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/t/nwnk/pbzcyrgr');
idgStorage.setRot13('tnyyrelNqOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/t/nwnk/nq');
idgStorage.setRot13('tnyyrelRkgraqrqYvfgOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/t/nwnk/rkgraqrqYvfg');
idgStorage.setRot13('negvpyrNwnkOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/n/nwnk');
idgStorage.setRot13('pbzcnalFpbhgNwnkOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/pbzcnal-fpbhg/nwnk');
idgStorage.setRot13('vaernqGrnfreNwnkOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/vaernqGrnfre/nwnk');
idgStorage.setRot13('negvpyrFunerIvnRZnvyCngu', 'uggcf://zvpebfbsg.pvb.qr/n/funerIvnRZnvy');
idgStorage.setRot13('negvpyrSrrqonpxCngu', 'uggcf://zvpebfbsg.pvb.qr/n/srrqonpxSbez');
idgStorage.setRot13('negvpyrArjfyrggreErpbzzraqngvba', 'uggcf://zvpebfbsg.pvb.qr/n/arjfyrggreErpbzzraqngvba');
idgStorage.setRot13('cerzvhzPbhcbaCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony/nwnk/cerzvhzpbhcba');
idgStorage.setRot13('vafvqreErtvfgreCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony/nwnk/ertvfgreVafvqreSbez');
idgStorage.setRot13('rqvgCebsvyrCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony/nwnk/rqvgCebsvyrSbez');
idgStorage.setRot13('qlaPunegWFBAOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/puneg/nwnk/puneg');
idgStorage.setRot13('qlaPunegPbyhzaWFBAOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/puneg/nwnk/pbyhza');
idgStorage.setRot13('ybtvaCbchcCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony/cbchc/ybtva');
idgStorage.setRot13('ybtbhgCbchcCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony');
idgStorage.setRot13('pbagnpgHeyfErdhrfg', 'uggcf://zvpebfbsg.pvb.qr/argmjrex/nwnk/erdhrfgPbagnpg');
idgStorage.setRot13('rkgraqnoyrYvfgNwnkOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/n/nwnk/rkgraqrqYvfg');
idgStorage.pagestreeroot = 17889;
idgStorage.pageId = 17898;
idgStorage.pagePage = 1;
idgStorage.social = {"tracking":{"enabled":false}};
idgStorage.adBlock = true;
var d = new Date();
d.setTime(d.getTime() + 60 * 60 * 24 * 2 * 1000);
document.cookie = "__adblocker=true; expires=" + d.toUTCString() + "; path=/";
idgStorage.ads = false;
idgStorage.imageGalleryAdvertAfter = 6;
idgStorage.videoPlayerId = '';
idgStorage.pianoAppId = '';
idgStorage.detailContentAvailable = true;
idgStorage.setRot13('qrgnvyPbagragGlcr', 'fs2po.zbqhyrf.vqt-ohaqyr.VqtNegvpyr.zbqryf.VqtNegvpyr');
idgStorage.setRot13('qrgnvyPbagragHey', 'uggcf://zvpebfbsg.pvb.qr/n/zfb-servurvg-haq-irenagjbeghat-shre-qribcf-ragjvpxyre,3652903');
idgStorage.detailContentIsSponsored = true;
idgStorage.detailContentIsNoAds = true;
idgStorage.detailContentId = 3652903;
idgStorage.detailContentPage = 1;
</script>
<script src="/advert/advert.js"></script>
<script>
idgRequestNonPersonalizedAds = false;
console.log('## idgRequestNonPersonalizedAds', idgRequestNonPersonalizedAds);
</script>
<script>
var cookies = document.cookie.split(';');
var css = [];
for (var c = 0; c < cookies.length; c++) {
var iO = cookies[c].indexOf('=');
var n = cookies[c].substr(0, iO);
var v = cookies[c].substr(iO+1);
n = n.replace(/^\s+|\s+$/g,"");
v = v.replace(/^\s+|\s+$/g,"");
if (n == 'closedDismissables') {
dIDs = v.split(',');
for(var i = 0; i < dIDs.length; i++) {
dID = dIDs[i].replace(/^\s+|\s+$/g,"")
if (dID.length) {
css[css.length] = '#' + dID + '.dismissable';
}
}
if (css.length) {
document.write('<style type="text/css">' + css.join(', ') + '{ display:none; }</style>');
}
break;
}
}
</script>
<script>
!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
permutive.addon('web', {
page: {
type: 'article',
tax: {
primaryCategories: ["personal productivity"],
secondaryCategories: ["software","digital transformation","devops","personal","technologies","software development","management","development approaches","innovation","applications"]
},
language: 'de',
audience: 'enterprise',
tags: ["Web Entwicklung","Microsoft","Open Source"],
gTax: {"primaryIds":[12],"secondaryIds":[2,567,244,4,1,241,560,242,564,3]},
keywords: ["microsoft","entwickler","heute","produkte","branche","nutzer","team","monat","wandel","nadella"],
description: "Digitale Produkte werden in jeder Branche entscheidend, und damit auch die Effizienz der Softwarearchitekten. Microsoft hat in den vergangenen Jahren seine eigene Softwareentwicklung radikal transformiert.",
ads: {
'enabled': idgStorage.adBlock,
'adblocker': idgStorage.ads
},
article: {"authors":[],"modifiedAt":"2020-11-22T08:06:00+01:00","publishedAt":"2020-11-22T08:06:00+01:00","isInsiderContent":false,"id":"3652903","type":"Online-Artikel","title":"Heute arbeiten Entwickler bei Microsoft viel autonomer und effizienter"}
}
});
</script>
<script async src="https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js"></script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PRTTMM2');</script>
<script type="text/javascript">
if(typeof idgStorage.bcCount === 'undefined' || typeof idgStorage.bcTime === 'undefined'){
idgStorage.bcCount = 0;
idgStorage.bcTime = 0;
}
idgStorage.bcInterval = setInterval(function () {
if(typeof idgStorage.dnbData !== 'undefined'){
idgStorage.bcCount = 0;
}
if (idgStorage.bcCount === 0) {
if (typeof __tcfapi == 'function') {
console.log('### __tcfapi found, loading blueconic');
var bcscript = document.createElement("script");
bcscript.async = true;
bcscript.type = "text/javascript";
var useSSL = "https:" == document.location.protocol;
bcscript.src = (useSSL ? "https:" : "http:") + "//cdn.blueconic.net/idg.js";
var node = document.getElementsByTagName("script")[0];
node.parentNode.insertBefore(bcscript, node);
}
clearInterval(idgStorage.bcInterval);
}
idgStorage.bcCount--;
}, idgStorage.bcTime);
</script>
</head>
<!-- Theme fix: clientSetting Search -->
<body class="body-root-page-17889 body-contenttype-idgarticle fp-responsive">
<!-- Theme fix: clientSetting 404 -->
<div id="mobile-menu-shadow"></div>
<div id="searchresults" style="display:none;"></div>
<div id="searchwrap" style="display:none;">
<img src="/img/onepager/recent.svg" alt="" height="1" width="1" border="0" />
<img src="/img/onepager/innovation.svg" alt="" height="1" width="1" border="0" />
<img src="/img/onepager/cloud.svg" alt="" height="1" width="1" border="0" />
<img src="/img/onepager/security.svg" alt="" height="1" width="1" border="0" />
<img src="/img/onepager/search.svg" alt="" height="1" width="1" border="0" />
<div id="searchshadow"></div>
<div id="searchclose" title="schließen"><i class="fas fa-times"></i><span>Suche schließen</span></div>
<div id="searchform">
<div class="searchformcell">
<div class="input-group">
<form action="https://microsoft.cio.de/p/suche,17890" method="GET">
<div id="loadinggif" class="nonevisible">
<img src="/img/onepager/loading-balls.svg" alt="" height="30" width="30">	
</div>
<div id="search-icon">
<i class="fas fa-search"></i>
</div>
<input id="query" name="query" class="form-control" value="" type="text" autofocus="autofocus" placeholder="Suchbegriff hier eingeben…" onfocus="this.value = this.value;">
<div class="input-group-btn">
<button type="submit" class="btn btn-danger">Jetzt suchen</button>
</div>
</form>
</div>
</div>
</div>
</div>
<div class="container idgContainerOuter" style="visibility:hidden;">
<div class="idgContainer idgContainerBordered">
<div class="idgTracking">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PRTTMM2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
idgStorage.gaData = {};
for (var i = 1; i <= 17; i++) {
idgStorage.gaData[i] = '';
}
</script>
<script>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</script>
<!-- Linkfeed -->
</div>
<header class="navyHeader">
<div class="navyHeaderWrap">
<div class="hub-title">
<a href="/" class="gotocat" title="COMPUTERWOCHE" data-menuanchor="sct-hpt">
Microsoft Story
</a>
</div>
<div class="onepager-navig">
<ul>
<li id="homemainnavi" style="width:0px;" data-menuanchor="sct-hpt" class="active">
<a href="/" id="nvg-hpt" class="mainnavi gotocat" title="Home"></a>
</li>
<li data-menuanchor="sct-17892" class="channel-link">
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Aktuelles - 17892" data-ga-action-type="click" data-ga-noninteractive="false" href="/p/aktuelles,17892" data-number="2" data-info="Aktuelles" data-url="/p/aktuelles,17892" id="nvg-17892" class="pics17892 mainnavi gotocat" title="Aktuelles">
<div title="Aktuelles" class="onepager-pics"></div>
<span>Aktuelles</span>
</a>
</li>
<li data-menuanchor="sct-17898" class="channel-link">
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Innovation - 17898" data-ga-action-type="click" data-ga-noninteractive="false" href="/p/innovation,17898" data-number="3" data-info="Innovation" data-url="/p/innovation,17898" id="nvg-17898" class="pics17898 mainnavi gotocat" title="Innovation">
<div title="Innovation" class="onepager-pics"></div>
<span>Innovation</span>
</a>
</li>
<li data-menuanchor="sct-17899" class="channel-link">
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Cloud - 17899" data-ga-action-type="click" data-ga-noninteractive="false" href="/p/cloud,17899" data-number="4" data-info="Cloud" data-url="/p/cloud,17899" id="nvg-17899" class="pics17899 mainnavi gotocat" title="Cloud">
<div title="Cloud" class="onepager-pics"></div>
<span>Cloud</span>
</a>
</li>
<li data-menuanchor="sct-17900" class="channel-link">
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Security - 17900" data-ga-action-type="click" data-ga-noninteractive="false" href="/p/security,17900" data-number="5" data-info="Security" data-url="/p/security,17900" id="nvg-17900" class="pics17900 mainnavi gotocat" title="Security">
<div title="Security" class="onepager-pics"></div>
<span>Security</span>
</a>
</li>
<li id="searchitem" >
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Suche - 17890" data-ga-action-type="click" data-ga-noninteractive="false" href="javascript:void(0)" id="nvgmob-search" class="pics-search mainnavi gotocat" title="Suche" data-gotocat="fdcpage-search">
<div title="Suche" class="onepager-pics"></div>
<span>Suche</span>
</a>
</li>
</ul>
</div>
<div class="hidden-xs sponsored-logos">
<a href="https://www.microsoft.com/de-de/" target="_blank" class="sponsor main-sponsor"><img src="/img/mso/ms.svg" /></a>
<a href="https://www.cio.de" target="_blank" class="sponsor idg-sponsor-first"><img src="/img/mso/cio.svg" /></a>
<a href="https://www.computerwoche.de" target="_blank" class="sponsor idg-sponsor-second"><img src="/img/mso/cw.svg" /></a>
</div>
<div id="burger-toggle" class="burger-menu hidden">
<i class="fa fa-bars"></i>
</div>
</div>
<div class="visible-xs sponsored-logos">
<a href="https://www.microsoft.com/de-de/" target="_blank" class="sponsor main-sponsor"><img src="/img/mso/ms.svg" /></a>
<a href="https://www.cio.de" target="_blank" class="sponsor idg-sponsor-first"><img src="/img/mso/cio.svg" /></a>
<a href="https://www.computerwoche.de" target="_blank" class="sponsor idg-sponsor-second"><img src="/img/mso/cw.svg" /></a>
</div>
</header>
<div class="idgContentWrapper">
<script type="text/javascript">
if (typeof(idgStorage) !== 'undefined') {
idgStorage.articleTitle = 'Heute arbeiten Entwickler bei Microsoft viel autonomer und effizienter';
}
</script>
<article class="idgArticleDetail"><div class="row"><div class="col-xs-12"><div class="article-background-image" style="background-image: url('//images.computerwoche.de/bdb/3261539/original.png');"></div><div id="article" class="fullpage-wrapper"><div class="article-navigator-left"><a class="article-back-button" href="#"><div class="arrow-left-wrapper"><i class="fa fa-chevron-left hvr-forward" aria-hidden="true"></i></div></a></div><div id="article-head" class="section article-first-section active"><div class="article-section-bg-image"><div class="article-head-wrapper"><div class="article-head"><h2>DevOps im Fokus</h2><h1>Heute arbeiten Entwickler bei Microsoft viel autonomer und effizienter</h1><div class="social-share-list-text"><span>Artikel teilen:</span></div><div class="social-share-list"><span class="social-icon"><a title="Facebook" href="https://www.facebook.com/sharer.php?u=https://microsoft.cio.de/3652903&amp;t=DevOps%20im%20Fokus%3A%20Heute%20arbeiten%20Entwickler%20bei%20Microsoft%20viel%20autonomer%20und%20effizienter" target="_blank" rel="noopener" class="tracksocial" data-network="Facebook" data-action="Share"><i class="fab fa-facebook-f"><!--Facebook--></i></a></span><span class="social-icon"><a title="Twitter" href="https://twitter.com/share?url=https://microsoft.cio.de/3652903&amp;text=DevOps%20im%20Fokus%3A%20Heute%20arbeiten%20Entwickler%20bei%20Microsoft%20viel%20autonomer%20und%20effizienter" target="_blank" rel="noopener" class="tracksocial" data-network="Twitter" data-action="Tweet"><i class="fab fa-twitter"><!--Twitter--></i></a></span><span class="social-icon"><a title="LinkedIn" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://microsoft.cio.de/3652903&amp;title=DevOps%20im%20Fokus%3A%20Heute%20arbeiten%20Entwickler%20bei%20Microsoft%20viel%20autonomer%20und%20effizienter" target="_blank" rel="noopener" class="tracksocial" data-network="LinkedIn" data-action="Share"><i class="fab fa-linkedin-in"><!--LinkedIn--></i></a></span><span class="social-icon"><a title="Xing" href="https://www.xing.com/app/user?op=share&amp;url=https://microsoft.cio.de/3652903;title=DevOps%20im%20Fokus%3A%20Heute%20arbeiten%20Entwickler%20bei%20Microsoft%20viel%20autonomer%20und%20effizienter" target="_blank" rel="noopener" class="tracksocial" data-network="XING" data-action="Share"><i class="fab fa-xing"><!--Xing--></i></a></span></div></div></div></div></div><div id="article-content" class="section article-second-section"><div class="article-body articlebody idgGalleryWidthHelper"><div><p>Mit mehr als 100.000 Entwicklern ist Microsoft einer der größten Software-Hersteller der Welt. Die Produktgruppen waren auch die Keimzelle der digitalen Transformation von Microsoft, die um 2006 begann und sich über Jahre erstreckte. Der Grund für den Wandel: Auch die Software-Branche steht seit gut 20 Jahren unter dem Druck des digitalen Wandels. </p><div class="clearfix"><!--clear--></div><figure class="thumbnail"><a target="_self" href="javascript:void(0);"><picture><source type="image/webp" data-srcset="//images.computerwoche.de/bdb/3330723/1066x600.webp"></source><img class="lazy img-responsive" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" border="0" alt="Die Software-Branche war schon früh Ausgangspunkt für einen Wandel. Entwickler mussten kreativer, agiler sowie effizienter werden– kurz: wettbewerbsfähiger." title="Die Software-Branche war schon früh Ausgangspunkt für einen Wandel. Entwickler mussten kreativer, agiler sowie effizienter werden– kurz: wettbewerbsfähiger."></picture></a><figcaption class="caption">Die Software-Branche war schon früh Ausgangspunkt für einen Wandel. Entwickler mussten kreativer, agiler sowie effizienter werden– kurz: wettbewerbsfähiger.<br><span class="idgImageSource">Foto: Microsoft</span></figcaption></figure><p>Dem gleichen Druck unterliegen heute Unternehmen aus jeder Branche, denn die Zukunft gehört dem Geschäft mit digitalen Produkten. Unternehmen werden zum Softwareanbieter und bauen ihr Geschäft um. Agilität und Innovationskraft spielen dabei eine große Rolle. Auf dieser Reise hat Microsoft schon ein großes Stück zurückgelegt. Und die Geschichte dieses Wandels birgt interessante Lehren für die Produktivität von Unternehmen.</p><div class="clearfix"><!--clear--></div><h3 id="header_EL_subheadingN1001D">Jeden zweiten Dienstag eines Monats war Patchday</h3><p>Anfang des Jahrtausends arbeiteten Microsofts Produktgruppen rund dreieinhalb Jahre daran, Visual Studio 2005 aus der Tür zu bekommen. Die Windows-Entwicklungszyklen erstreckten sich im Schnitt auch über drei Jahre, SQL dauerte noch länger. Aufgrund der langen Produktionszyklen war es für Software-Unternehmen nicht einfach, die Anforderungen an künftige Releases zu definieren.</p><p>Starre und komplizierte Prozesse taten ihr übriges. Es war an der Tagesordnung, dass Kunden manch neue Funktion nicht nutzen konnten, weil die Software unausgereift oder falsch geplant war - auch weil sich der Markt in der Zwischenzeit weiterentwickelt hatte. Jeden zweiten Dienstag im Monat lieferte Microsoft daher gesammelt ein Update mit Aktualisierungen. </p><p>Unter dem neuen CEO Satya Nadella fällte Microsoft 2014 die Entscheidung, den traditionellen Zyklus der Branche endgültig zu durchbrechen und die heterogenen Entwicklungsumgebungen zu vereinheitlichen sowie zu modernisieren. "Das war der Startschuss für das One Engineering System (1ES), das so gut sein musste wie die Entwicklungssysteme der bekannten Cloud-Companies", erinnert sich Sam Guckenheimer, der 2003 zu Microsoft kam. Zuvor war der Manager für die Produktlinienstrategie bei Rational zuständig, einem Anbieter von Entwicklungs-Tools. </p><div class="clearfix"><!--clear--></div><figure class="thumbnail"><a target="_self" href="javascript:void(0);"><picture><source type="image/webp" data-srcset="//images.computerwoche.de/bdb/3330722/1066x600.webp"></source><img class="lazy img-responsive" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" border="0" alt="Sam Guckenheimer begleitete seit 2003 die Transformation bei Microsoft und ist heute Product Owner der Cloud-Entwicklungsplattform Azure DevOps." title="Sam Guckenheimer begleitete seit 2003 die Transformation bei Microsoft und ist heute Product Owner der Cloud-Entwicklungsplattform Azure DevOps."></picture></a><figcaption class="caption">Sam Guckenheimer begleitete seit 2003 die Transformation bei Microsoft und ist heute Product Owner der Cloud-Entwicklungsplattform Azure DevOps.<br><span class="idgImageSource">Foto: Microsoft</span></figcaption></figure><div class="clearfix"><!--clear--></div><h3 id="header_EL_subheadingN10045">Eat your own dogfood</h3><p>Seit jeher setzt Microsoft seine eigenen Produkte selbst ein und so basiert auch das One Engineering System auf den eignen Produkten. Microsoft verfügt über ein umfangreiches Portfolio an Plattformen und Tools für die Entwicklung: von der Cloudplattform Azure über GitHub bis zu Visual Studio. "Die Verbindung der Produktlinien von Azure DevOps und der Open-Source-Plattform GitHub ist die Grundlage unserer eigenen Transformation", erklärt Guckenheimer. "Und die Erfahrungen aus unserem eigenen Change gingen natürlich in die Anforderungen unserer Tools und Services ein."</p><p>Der Wandel bei Microsoft basiert auf fünf Grundpfeilern: konsequente Orientierung am Kunden, volle Verantwortlichkeit ("You Build It, You Love It"), Team-Autonomie, ein neues Qualitätsparadigma sowie Infrastruktur als flexible Ressource. Und er war erfolgreich: Heute bearbeiten die Entwickler täglich etwa 85.000 Deployments, 500.000 Work Items werden aktualisiert, so Guckenheimer. </p><div class="clearfix"><!--clear--></div><h3 id="header_EL_subheadingN1005B">Ping-Pong statt langer Abschlag</h3><p>Grundlage ist ein kontinuierliches Feedback der Anwender, aus dem sich ein optimaler Regelkreis entwickelt: Statt langer Abschläge wie beim Golf spielen sich Produktgruppen und Nutzer die Bälle in schneller Folge zu und verbessern so die Produkte. "Nun liefern wir kontinuierlich innerhalb von Tagen und Wochen aus." Möglich wird dies vor allem durch das stetige Feedback der Nutzer und die Fähigkeit, die notwendigen Verbesserungen in kurzer Zeit zu entwickeln, zu testen und freizugeben.</p><p>Der Best Case? Heute könne innerhalb eines Tages auf einen Twitter-Post reagiert werden, wenn Nutzer nach einem Feature fragen. Dann meldet sich beispielsweise das Visual Studio Code Team am Nachmittag mit der Nachricht zurück, dass die Funktion nun zur Verfügung steht. "Das ist nicht die Norm", sagt Guckenheimer, "aber es zeigt, was inzwischen möglich ist". </p><div class="clearfix"><!--clear--></div><figure class="thumbnail"><a target="_self" href="javascript:void(0);"><picture><source type="image/webp" data-srcset="//images.computerwoche.de/bdb/3330724/1066x600.webp"></source><img class="lazy img-responsive" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" border="0" alt="Nach mehr als zehn Jahren hat Microsoft die DevOps-Transformation vollzogen. Der wichtigste Nutzen dabei: Unter dem Strich setzt Microsoft nun Veränderungen in Wochen um, nicht mehr in Jahren." title="Nach mehr als zehn Jahren hat Microsoft die DevOps-Transformation vollzogen. Der wichtigste Nutzen dabei: Unter dem Strich setzt Microsoft nun Veränderungen in Wochen um, nicht mehr in Jahren."></picture></a><figcaption class="caption">Nach mehr als zehn Jahren hat Microsoft die DevOps-Transformation vollzogen. Der wichtigste Nutzen dabei: Unter dem Strich setzt Microsoft nun Veränderungen in Wochen um, nicht mehr in Jahren.<br><span class="idgImageSource">Foto: Microsoft</span></figcaption></figure><p>Laut Software-Manager Guckenheimer hilft das Feedback von außen dabei, die Prioritäten und Ressourcen richtig zu setzen. Seine Daumenregel: In einem Drittel der Annahmen zu den Kundenwünschen hat man recht, ein Drittel der Annahmen bringt eine Verbesserung ohne signifikanten Nutzen für den Kunden, das letzte Drittel der Innovationen erfüllt die Erwartungen der Anwender nicht. "Wir wissen das, weil wir das alles messen." </p><div class="clearfix"><!--clear--></div><h3 id="header_EL_subheadingN1007F">Kundenfeedback digital in die Wertschöpfung integriert</h3><p>Die Konsequenz für Microsoft lag darin, Feedback gezielt zu sammeln, auszuwerten und so die Trefferrate zu steigern. Heute wird hinter den Kulissen akribisch analysiert, was für die Nutzer funktioniert und was nicht, mit jedem Lieferzyklus werden die Programme aktualisiert und kontinuierlich verbessert. Und je höher die Frequenz der Auslieferung ist, desto mehr steigt der Nutzen der Programme für den Anwender. Was nicht funktioniert, wird möglichst frühzeitig wieder abgestellt. "Telemetriedaten zeigen uns, inwieweit unsere Hypothesen zu den Veränderungen aufgegangen sind."</p><p>Diese Herangehensweise ist inzwischen für Unternehmen aller Branchen relevant, in denen Software und Datenanalysen die Produktentwicklung beschleunigen. Beispiel Automotive mit V-Modell, Automotive SPICE und ISO-Compliance: Im Wettbewerb autonomer Fahrzeuge müssen sechs Monate - von der Definition der Anforderung bis zum Release und Einsatz in der Testflotte - in nur noch einer Woche verdichtet werden. </p><p>Auf traditionelle Art - mit Übergaben zwischen allen beteiligten Silos - gelinge dies nicht, argumentiert Guckenheimer: "Ziel ist daher ein kontinuierlicher Feedback-Zyklus mit Telemetrie aus dem Auto sowie OTA-Updates." Diese Art der Disruption - wie von Tesla bekannt - alarmiere die meisten Unternehmen, selbst aus konservativen Industriezweigen. "Das Mantra, dass sich jede Firma in eine Software-Company verändert, ist wahr. Sie müssen die Grundlage schaffen, um künftig auf Basis von Daten zu messen, zu validieren und zu entscheiden."</p>
</div>
</div>
<div class="understitial-wrapper">
<div class="understitial-background-image" style="background-image: url('//images.computerwoche.de/bdb/3326799/original.jpg')"></div>
<div class="understitial-content-wrapper">
<div class="understitial-type">
<i class="fas fa-code developer"></i>
<span>Developer</span>
</div>
<h4>
<a href="https://www.microsoft.com/de-de/aktionen/immersion-workshops?wt.mc_id=AID3023383_QSG_PD_SCL_474661" target="_blank">
Geballtes Wissen zu Cloud Native, .NET und Co.
</a>
</h4>
<p>
Erweitern Sie Ihre technischen Kompetenzen rund um Cloud Native, .NET und KI &mdash; und lernen Sie inspirierende Best Practices und Trends kennen.
</p>
<button>
<a href="https://www.microsoft.com/de-de/aktionen/immersion-workshops?wt.mc_id=AID3023383_QSG_PD_SCL_474661" target="_blank">Jetzt anmelden</a>
</button>
</div>
</div>
<div class="article-body articlebody idgGalleryWidthHelper">
<div>
<div class="clearfix"><!--clear--></div><h3 id="header_EL_subheadingN100A6">Verantwortung führt zu Aktivität </h3><p>Die von Guckenheimer gewählte Analogie vom Golfspiel mit seinen langen Abschlägen und dem Tischtennis mit schnellen Ballwechseln erstreckt sich auch auf den Betrieb der Anwendungen. So ist jeder Entwickler eines Feature Teams regelmäßig verantwortlich für den produktiven Service und den Support. "Wenn es einen Live Site Incident gibt", berichtet Guckenheimer, "muss dieser Entwickler innerhalb von fünf Minuten an dem Problem arbeiten beziehungsweise innerhalb von 15 Minuten außerhalb der normalen Arbeitszeiten." </p><p>Dies habe aber auch zur Folge, dass man als Entwickler die Schmerzen der Kunden sieht und eigene Defizite in der Telemetrie, den Tests oder dem Troubleshooting erkennt. Alle fehlenden Stücke aus dem Life Site Incident werden gesammelt als Improvement Items, für das "validierte Lernen". Mit Work Items wiederum wird die Quality of Service verbessert, und das Ticket für den Incident kann erst geschlossen werden, wenn wie die Repair Items aus dem Backlog erfasst und in einem Sprint abgearbeitet wurden. "Durch die Feedback-Schleife entwickeln sich Probleme aus allen Bereichen der Software-Entwicklung zu Chancen zum Lernen, um das Leben der Kunden zu verbessern."</p><div class="clearfix"><!--clear--></div><h3 id="header_EL_subheadingN100BC">Aktivität führt zur Zufriedenheit</h3><p>Die Umstellung brachte jedoch nicht nur für die Anwender der Tools Vorteile, sondern wirkte sich auch positiv auf die eigenen Mitarbeiter aus. Die Zufriedenheit der Entwickler und die Attraktivität als Arbeitgeber entwickelten sich zu einem konkreten Ziel. So drehen sich die heutigen Top-Metriken für den Erfolg bei Microsoft um die Zufriedenheit der Mitarbeiter, berichtet Guckenheimer aus der Praxis: "Wir fragen unsere Developer regelmäßig, wie glücklich sie mit Prozessen, Tools oder Arbeitsumgebungen sind und wie gut sie dadurch bei der Arbeit unterstützt werden."</p><p>Ein Indikator für die Reife von Teams und Organisationen ist der Grad der Autonomie. Hier empfiehlt Oppenheimer eine Kennzahl, mit der Entwickler ihre Autonomie bestimmen können: 1 geteilt durch die Anzahl der Genehmigungen außerhalb des Feature-Teams, um den Code-Change in die Produktion zu bringen. Könne das Team den Code selbst prüfen und die Freigabe erteilen, sei das "Infinite Autonomy", so Guckenheimer. "Eine Autonomie von 1 mit nur einer Genehmigungsschleife ist großartig - allerdings extrem selten. Zehn Freigaberunden bedeuten einen Grad von 0,1 - das ist heute nicht mehr zeitgemäß." </p><p>Auch Microsoft-CEO Satya Nadella hat die Befindlichkeiten der Mitarbeiter aufgriffen und zur Chefsache erklärt. So machte er den Wandel der Unternehmenskultur und das 1ES zum Gegenstand des monatlichen Town Hall-Meetings in Redmond - ein Projekt, das wegen diverser Anpassungen rund drei Jahre gedauert hatte. "Nadellas Ansprache unter anderem über die Verbesserungen für unsere Software-Entwickler war ein starkes Symbol dafür, dass das Management auf die eigenen Entwickler gehört und die alten Tools und Prozesse modernisiert hat." Heute nutzen rund 105.000 interne Entwickler Azure DevOps, mehr als 25.000 setzen GitHub ein.</p><p>Guckenheimer zufolge stellt CEO Nadella erfolgreiche Projekte bewusst ins Rampenlicht, damit die anderen Abteilungen sich fragen, "warum sie nicht zu der Party eingeladen sind". Ein mächtiges Werkzeug: "Indem man dieses Verlangen bei Kreativen weckt, lassen sich traditionelle Strukturen leichter aufbrechen und modernisieren."</p><div class="clearfix"><!--clear--></div></div><div class="article-end-social-media"><div class="social-share-list-text"><span>Artikel teilen:</span></div><div class="social-share-list"><span class="social-icon"><a title="Facebook" href="https://www.facebook.com/sharer.php?u=https://microsoft.cio.de/3652903&amp;t=DevOps%20im%20Fokus%3A%20Heute%20arbeiten%20Entwickler%20bei%20Microsoft%20viel%20autonomer%20und%20effizienter" target="_blank" rel="noopener" class="tracksocial" data-network="Facebook" data-action="Share"><i class="fab fa-facebook-f"><!--Facebook--></i></a></span><span class="social-icon"><a title="Twitter" href="https://twitter.com/share?url=https://microsoft.cio.de/3652903&amp;text=DevOps%20im%20Fokus%3A%20Heute%20arbeiten%20Entwickler%20bei%20Microsoft%20viel%20autonomer%20und%20effizienter" target="_blank" rel="noopener" class="tracksocial" data-network="Twitter" data-action="Tweet"><i class="fab fa-twitter"><!--Twitter--></i></a></span><span class="social-icon"><a title="LinkedIn" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://microsoft.cio.de/3652903&amp;title=DevOps%20im%20Fokus%3A%20Heute%20arbeiten%20Entwickler%20bei%20Microsoft%20viel%20autonomer%20und%20effizienter" target="_blank" rel="noopener" class="tracksocial" data-network="LinkedIn" data-action="Share"><i class="fab fa-linkedin-in"><!--LinkedIn--></i></a></span><span class="social-icon"><a title="Xing" href="https://www.xing.com/app/user?op=share&amp;url=https://microsoft.cio.de/3652903;title=DevOps%20im%20Fokus%3A%20Heute%20arbeiten%20Entwickler%20bei%20Microsoft%20viel%20autonomer%20und%20effizienter" target="_blank" rel="noopener" class="tracksocial" data-network="XING" data-action="Share"><i class="fab fa-xing"><!--Xing--></i></a></span></div></div></div><div class="article-end-next-article"><div class="articlenext-text-wrapper"><a href="/a/das-passiert-wenn-unternehmen-ihren-mitarbeitern-mehr-autonomie-anbieten,3652902" rel="nofollow" id="npnext" class="npbutton npbnext" title="Nächster Artikel"><h2>Nächster Artikel: Wie ein radikaler Change den Entwicklern mehr Autonomie bescherte</h2><span class="hvr-bob"><i class="fa fa-chevron-down" aria-hidden="true"></i></span></a></div></div></div><div class="article-footer"><ul class="list-inline"><li><a href="https://www.computerwoche.de/p/datenschutz,265" title="Datenschutz" target="_blank">Datenschutz</a></li><li><a href="https://www.computerwoche.de/p/cookie-policy,17707" title="Cookie Policy" target="_blank">Cookie Policy</a></li><li><a href="https://www.computerwoche.de/p/impressum,3716" title="Impressum" target="_blank">Impressum</a></li><li><span>© IDG Business Media GmbH</span></li></ul></div></div></div></div></article>
<script type="application/ld+json" id="articleJson">
{"dateModified":"2020-11-22T20:06:00Z","publisher":{"@type":"Organization","logo":{"height":57,"@type":"ImageObject","url":"https://microsoft.cio.de/includes/images/amp/logo/Microsoft.png","width":182},"name":"Microsoft"},"datePublished":"2020-11-22T20:06:00Z","@context":"http://schema.org","@type":"NewsArticle","headline":"Heute arbeiten Entwickler bei Microsoft viel autonomer und effizienter","image":{"height":675,"@type":"ImageObject","url":"https://images.computerwoche.de/bdb/3261539/1200x.jpg","width":1200},"mainEntityOfPage":{"@type":"WebPage","@id":"https://microsoft.cio.de/a/mso-freiheit-und-verantwortung-fuer-devops-entwickler,3652903"},"author":{"@type":"Organization","name":"Microsoft"},"description":"Digitale Produkte werden in jeder Branche entscheidend, und damit auch die Effizienz der Softwarearchitekten. Microsoft hat in den vergangenen Jahren seine eigene Softwareentwicklung radikal transformiert."}
</script>
<div class="modal fade" id="modalArticleShareEMail">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
<h4 class="modal-title">Per E-Mail versenden</h4>
</div>
<div class="modal-body">&nbsp;</div>
<div class="modal-footer">
<button type="button" class="btn btn-default" data-dismiss="modal">Schließen</button>
<button type="button" class="btn btn-danger" onclick="$('#modalArticleShareEMail form').submit()">Senden</button>
</div>
</div>
</div>
</div>
<div class="modal fade" id="modalArticlePdfDownload">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
<h4 class="modal-title">Artikel als PDF downloaden</h4>
</div>
<div class="modal-body">&nbsp;</div>
</div>
</div>
</div>
<div class="modal hide fade idgModalMedia in" id="modalArticleAuthor">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal">×</button>
<h3>&Uuml;ber den Autor</h3>
</div>
<div class="modal-body">
&nbsp;
</div>
<div class="modal-footer">
<a href="#" class="btn btn-close" data-dismiss="modal">Schlie&szlig;en</a>
</div>
</div>
</div>
</div>
</div>
<script src="https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js"></script>
<script>
WebFont.load({
custom: {
families: [
'Open Sans:400,700',
'Open Sans Condensed:300,700',
],
urls: [
'https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700|Open+Sans+Condensed%3A300%2C700&display=swap'
]
}
});
</script>
<script src="/includes/compiled/??001_core.min.js,010_themes.onepager.min.js,015_clients.mso.min.js?v=202102031658"></script>
<!--
page info section .......................................................
page: 17898
host: microsoft.cio.de
environment: aws
client: mso
cache: true
date: 04.02.2021 05:08:34
execution time: 0.569
-->
<script>
if (typeof console == 'object') {
console.log('page: 17898');
console.log('host: microsoft.cio.de');
console.log('environment: aws');
console.log('client: mso');
console.log('cache: true');
console.log('date: 04.02.2021 05:08:34');
console.log('execution time: 0.569');
}
</script>
</body>
<!--
article info section ....................................................
article: 3652903
date: 04.02.2021 05:08:34
modification date: 03.02.2021 17:51:14
-->
</html>
