<!DOCTYPE html><html lang="de" prefix="og: http://ogp.me/ns#">	
<head>
<link href="https://fonts.googleapis.com" rel="preconnect" crossorigin>
<link rel="preload" href="https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js" as="script">
<link href="https://www.google-analytics.com" rel="preconnect" crossorigin>
<link href="https://api.permutive.com" rel="preconnect" crossorigin>
<link href="https://de.ioam.de" rel="preconnect" crossorigin>
<link href="https://script.ioam.de" rel="preconnect" crossorigin>
<link href="https://tt.onthe.io" rel="preconnect" crossorigin>
<link href="https://www.googletagmanager.com" rel="preconnect" crossorigin>
<link href="https://images.computerwoche.de" rel="preconnect" crossorigin>
<meta http-equiv="Content-type" content="text&#x2f;html&#x3b;&#x20;charset&#x3d;utf-8" />
<title>5 Ansätze für Green Coding: Ob Hardware effizient genutzt wird, entscheidet der Code. So optimieren Sie ihn. - Microsoft</title>
<script>
/* Vendor IDs */
var vendorIds = {
'blueconic': '5eb32dea09c3f947e75e6f02',
'google_admanager': '5e74df5ff443bb795772df9c',
'google_analytics': '5e542b3a4cd8884eb41b5a72',
'google_advertising_products': '5f1aada6b8e05c306c0597d7',
'twitter': '5e71760b69966540e4554f01',
'facebook': '5e716fc09a0b5040d575080f',
'linkedin': '5f2d22a6b8e05c02aa283b3c',
'triblio': '5f2bf89e2b87b72624acb6fa',
'permutive_inc': '5f369a02b8e05c0ee351e350',
'permutive_ltd': '5f369a02b8e05c2f2d546a40',
'dun_and_bradstreet': '5f02efc0b8e05c2e742a3a45'
};
/* Purpose IDs */
var purposeIds = {
'store_access_on_device': '5ea7dfd36ede87504f7dedc5',
'select_personalised_content': '5ea7dfd36ede87504f7df18d',
'select_personalised_ads': '5ea7dfd36ede87504f7df04e',
'select_basic_ads': '5ea7dfd36ede87504f7deeaf',
'create_personalised_ads_profile': '5ea7dfd36ede87504f7def8d',
'create_personalised_content_profile': '5ea7dfd36ede87504f7df117',
'measure_ads_performance': '5ea7dfd36ede87504f7df1f7',
'measure_content_performance': '5ea7dfd36ede87504f7df2f3',
'apply_market_research': '5ea7dfd36ede87504f7df378',
'develop_and_improve_products': '5ea7dfd36ede87504f7df425'
};
var social_media_purpose_id = '5f1019609c10086dcb659fba';
var mauticPurposes = {
0: 'store_access_on_device',
1: 'select_personalised_content',
2: 'select_personalised_ads',
3: 'create_personalised_ads_profile',
4: 'create_personalised_content_profile',
5: 'measure_ads_performance',
6: 'apply_market_research',
7: 'develop_and_improve_products'
};
var ontheioPurposes = {
0: 'store_access_on_device',
1: 'create_personalised_content_profile',
2: 'measure_content_performance',
3: 'apply_market_research',
4: 'develop_and_improve_products'
};
/* Purpose IDs */
var doubleclickPurposes = {
0: 'store_access_on_device',
1: 'select_personalised_content',
2: 'select_personalised_ads',
3: 'select_basic_ads',
4: 'create_personalised_ads_profile',
5: 'create_personalised_content_profile',
6: 'measure_ads_performance',
7: 'measure_content_performance',
8: 'apply_market_research',
9: 'develop_and_improve_products'
};
let consentedCustomVendors = [];
let consentedPurposes = [];
let vendorGrants = {};
window.mauticConsent = false;
window.ontheioConsent = false;
window.doubleclickConsent = false;
/*
* Just define this here and default to false to avoid console errors
* i.e. (checkConsent is not defined)
* if for some reason the event-listener does not fire (in time).
*/
window.checkConsent = function() {
return false;
};
</script>
<script>
/*
* debugging via localStorage.cmpDebugging
* localStorage.setItem('cmpDebugging', true)
*/
var sourcepointCmpDebugging = function() {
if (typeof(localStorage) !== 'undefined') {
return (localStorage.getItem('cmpDebugging') === 'true');
}
return false;
};
window.cmpDebugger = sourcepointCmpDebugging() ? console.log : function(){};
</script>
<!--start Sourcepoint tcfv2 code-->
<script>
cmpDebugger('### Serving CMP v2');
</script>
<script type="text/javascript">
!function () { var e = function () { var e, t = "__tcfapiLocator", a = [], n = window; for (; n;) { try { if (n.frames[t]) { e = n; break } } catch (e) { } if (n === window.top) break; n = n.parent } e || (!function e() { var a = n.document, r = !!n.frames[t]; if (!r) if (a.body) { var i = a.createElement("iframe"); i.style.cssText = "display:none", i.name = t, a.body.appendChild(i) } else setTimeout(e, 5); return !r }(), n.__tcfapi = function () { for (var e, t = arguments.length, n = new Array(t), r = 0; r < t; r++)n[r] = arguments[r]; if (!n.length) return a; if ("setGdprApplies" === n[0]) n.length > 3 && 2 === parseInt(n[1], 10) && "boolean" == typeof n[3] && (e = n[3], "function" == typeof n[2] && n[2]("set", !0)); else if ("ping" === n[0]) { var i = { gdprApplies: e, cmpLoaded: !1, cmpStatus: "stub" }; "function" == typeof n[2] && n[2](i) } else a.push(n) }, n.addEventListener("message", (function (e) { var t = "string" == typeof e.data, a = {}; try { a = t ? JSON.parse(e.data) : e.data } catch (e) { } var n = a.__tcfapiCall; n && window.__tcfapi(n.command, n.version, (function (a, r) { var i = { __tcfapiReturn: { returnValue: a, success: r, callId: n.callId } }; t && (i = JSON.stringify(i)), e.source.postMessage(i, "*") }), n.parameter) }), !1)) }; "undefined" != typeof module ? module.exports = e : e() }();
</script>
<script>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</script>
<script src="https://cmp2.cio.de/wrapperMessagingWithoutDetection.js"></script>
<!-- end Sourcepoint tcfv2 code-->
<!-- CCPA for CSOONLINE -->
<!-- __tcfapi callbacks -->
<script>
if(sourcepointCmpDebugging) {
console.group('__tcfapi tests');
};
/* tcfapi.ping */
cmpDebugger('### Testing __tcfapi.ping:');
__tcfapi('ping', 2, function(pingReturn) {
cmpDebugger('### __tcfapi.ping returned:', pingReturn);
});
/* tcfapi.getTCData */
cmpDebugger('### Testing __tcfapi.getTCData:');
__tcfapi('getTCData', 2, function(tcData, success) {
cmpDebugger('### __tcfapi.getTCData returned:', tcData, success);
});
/* tcfapi.getCustomVendorConsents */
cmpDebugger('### Testing __tcfapi.getCustomVendorConsents:');
__tcfapi('getCustomVendorConsents', 2, function(vendorConsents, success) {
cmpDebugger('### __tcfapi.getCustomVendorConsents returned:', vendorConsents, success);
});
if(sourcepointCmpDebugging) {
console.groupEnd('__tcfapi tests');
};
</script>
<script data-obct type = "text/javascript">
/** DO NOT MODIFY THIS CODE**/
!function(_window, _document) {
var OB_ADV_ID = '00433173edb38126157160e3c3e6f9ae10';
if (_window.obApi) {
var toArray = function(object) {
return Object.prototype.toString.call(object) === '[object Array]' ? object : [object];
};
_window.obApi.marketerId = toArray(_window.obApi.marketerId).concat(toArray(OB_ADV_ID));
return;
}
var api = _window.obApi = function() {
api.dispatch ? api.dispatch.apply(api, arguments) : api.queue.push(arguments);
};
api.version = '1.1';
api.loaded = true;
api.marketerId = OB_ADV_ID;
api.queue = [];
var tag = _document.createElement('script');
tag.async = true;
tag.src = '//amplify.outbrain.com/cp/obtp.js';
tag.type = 'text/javascript';
var script = _document.getElementsByTagName('script')[0];
script.parentNode.insertBefore(tag, script);
}(window, document);
obApi('track', 'PAGE_VIEW');
</script>
<script>
__tcfapi('addEventListener', 2, function(tcData, success) {
if ( success && (tcData.eventStatus === 'tcloaded' || tcData.eventStatus === 'useractioncomplete') ) {
if(doubleclickConsent) {
(function() {
var a = String(Math.floor(Math.random() * 10000000000000000));
new Image().src = 'https://pubads.g.doubleclick.net/activity;dc_iu=/8456/DFPAudiencePixel;ord=' + a + ';dc_seg=6897146533?';
})();
}
/* remove event listener to avoid double-doubleclick */
__tcfapi('removeEventListener', 2, function(success) {
if (success) {
cmpDebugger('### mso head.cfm eventListener: removeEventListener:', tcData.listenerId);
}
}, tcData.listenerId);
};
});
</script>
<meta content="width=device-width,minimum-scale=1,maximum-scale=1,initial-scale=1" name="viewport" />
<meta content="noodp" name="robots" />
<meta content="Code entscheidet, wie effizient die Hardware genutzt wird. Daher gibt es in der Software-Entwicklung viele Aspekte, um IT nachhaltig zu optimieren." name="description" />
<meta content="" name="keywords" />
<meta content="" name="news_keywords" />
<meta content="5 Ansätze für Green Coding: Ob Hardware effizient genutzt wird, entscheidet der Code. So optimieren Sie ihn." property="og:title" name="og:title" />
<meta content="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947" property="og:url" name="og:url" />
<meta content="Code entscheidet, wie effizient die Hardware genutzt wird. Daher gibt es in der Software-Entwicklung viele Aspekte, um IT nachhaltig zu optimieren." property="og:description" name="og:description" />
<meta content="summary_large_image" name="twitter:card" />
<meta content="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947" name="twitter:url" />
<meta content="5 Ansätze für Green Coding: Ob Hardware effizient genutzt wird, entscheidet der Code. So optimieren Sie ihn." name="twitter:title" />
<meta content="Code entscheidet, wie effizient die Hardware genutzt wird. Daher gibt es in der Software-Entwicklung viele Aspekte, um IT nachhaltig zu optimieren." name="twitter:description" />
<meta content="@" name="twitter:site" />
<meta content="https://images.computerwoche.de/bdb/3351413/640x360.jpg" property="og:image" name="og:image" />
<meta content="image/jpg" property="og:image:type" name="og:image:type" />
<meta content="640" property="og:image:width" name="og:image:width" />
<meta content="360" property="og:image:height" name="og:image:height" />
<meta content="https://images.computerwoche.de/bdb/3351413/640x360.jpg" name="twitter:image" />
<meta content="Sponsored" name="outbrainsection" />
<link href="https&#x3a;&#x2f;&#x2f;microsoft.cio.de&#x2f;a&#x2f;ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947" rel="canonical"></link>
<link href="https&#x3a;&#x2f;&#x2f;microsoft.cio.de&#x2f;a&#x2f;amp&#x2f;ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947" rel="amphtml" type="text&#x2f;html"></link>
<link rel="icon" href="/favicon.ico" type="image/x-icon" sizes="48x48">
<link rel="icon" href="/favicon.png" type="image/png" sizes="256x256">
<link rel="stylesheet" href="/includes/compiled/001_core.min.css?v=202202061158" media="all" />
<link rel="stylesheet" href="/includes/compiled/010_themes.onepager.min.css?v=202202061158" media="all" />
<link rel="stylesheet" href="/includes/compiled/015_clients.mso.min.css?v=202202061158" media="all" />
<script>
var idgStorage = new Object();
idgStorage.delayedFunctions = new Array();
String.prototype.rot13 = function(s) { return (s ? s : this).split('').map(function(_) { if (!_.match(/[A-Za-z]/)) return _; c = Math.floor(_.charCodeAt(0) / 97); k = (_.toLowerCase().charCodeAt(0) - 83) % 26 || 26; return String.fromCharCode(k + ((c == 0) ? 64 : 96));}).join('');};
idgStorage.setRot13 = function(key, value) {this[key.rot13()] = value.rot13()};
idgStorage.set = function(key, value) {this[key] = value};
idgStorage.dump = function() {console.log(this)};
idgStorage.ibw = (window.innerWidth);
idgStorage.ibh = (window.innerHeight);
idgStorage.currentStatusId = 5;
idgStorage.setRot13('raivebazrag', 'njf');
idgStorage.setRot13('pyvragFubegphg', 'zfb');
idgStorage.setRot13('vqtGurzr', 'barcntre');
idgStorage.setRot13('vzntrOnfrcngu', 'uggcf://vzntrf.pbzchgrejbpur.qr/oqo/');
idgStorage.setRot13('vzntrOnfrcnguCe','//vzntrf.pbzchgrejbpur.qr/oqo/');
idgStorage.setRot13('tnyyrelWFBAOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/t/nwnk/pbzcyrgr');
idgStorage.setRot13('tnyyrelNqOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/t/nwnk/nq');
idgStorage.setRot13('tnyyrelRkgraqrqYvfgOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/t/nwnk/rkgraqrqYvfg');
idgStorage.setRot13('negvpyrNwnkOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/n/nwnk');
idgStorage.setRot13('pbzcnalFpbhgNwnkOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/pbzcnal-fpbhg/nwnk');
idgStorage.setRot13('vaernqGrnfreNwnkOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/vaernqGrnfre/nwnk');
idgStorage.setRot13('negvpyrFunerIvnRZnvyCngu', 'uggcf://zvpebfbsg.pvb.qr/n/funerIvnRZnvy');
idgStorage.setRot13('negvpyrSrrqonpxCngu', 'uggcf://zvpebfbsg.pvb.qr/n/srrqonpxSbez');
idgStorage.setRot13('negvpyrArjfyrggreErpbzzraqngvba', 'uggcf://zvpebfbsg.pvb.qr/n/arjfyrggreErpbzzraqngvba');
idgStorage.setRot13('cerzvhzPbhcbaCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony/nwnk/cerzvhzpbhcba');
idgStorage.setRot13('vafvqreErtvfgreCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony/nwnk/ertvfgreVafvqreSbez');
idgStorage.setRot13('rqvgCebsvyrCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony/nwnk/rqvgCebsvyrSbez');
idgStorage.setRot13('qlaPunegWFBAOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/puneg/nwnk/puneg');
idgStorage.setRot13('qlaPunegPbyhzaWFBAOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/puneg/nwnk/pbyhza');
idgStorage.setRot13('ybtvaCbchcCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony/cbchc/ybtva');
idgStorage.setRot13('ybtbhgCbchcCngu', 'uggcf://zvpebfbsg.pvb.qr/tybony');
idgStorage.setRot13('pbagnpgHeyfErdhrfg', 'uggcf://zvpebfbsg.pvb.qr/argmjrex/nwnk/erdhrfgPbagnpg');
idgStorage.setRot13('rkgraqnoyrYvfgNwnkOnfrcngu', 'uggcf://zvpebfbsg.pvb.qr/n/nwnk/rkgraqrqYvfg');
idgStorage.pagestreeroot = 17889;
idgStorage.pageId = 17956;
idgStorage.pagePage = 1;
idgStorage.social = {"tracking":{"enabled":false}};
idgStorage.adBlock = true;
var d = new Date();
d.setTime(d.getTime() + 60 * 60 * 24 * 2 * 1000);
document.cookie = "__adblocker=true; expires=" + d.toUTCString() + "; path=/";
idgStorage.ads = false;
idgStorage.imageGalleryAdvertAfter = 6;
idgStorage.videoPlayerId = '';
idgStorage.pianoAppId = '';
idgStorage.detailContentAvailable = true;
idgStorage.setRot13('qrgnvyPbagragGlcr', 'fs2po.zbqhyrf.vqt-ohaqyr.VqtNegvpyr.zbqryf.VqtNegvpyr');
idgStorage.setRot13('qrgnvyPbagragHey', 'uggcf://zvpebfbsg.pvb.qr/n/bo-uneqjner-rssvmvrag-trahgmg-jveq-ragfpurvqrg-qre-pbqr-fb-bcgvzvrera-fvr-vua,3652947');
idgStorage.detailContentIsSponsored = true;
idgStorage.detailContentIsNoAds = true;
idgStorage.detailContentId = 3652947;
idgStorage.detailContentPage = 1;
</script>
<script src="/advert/advert.js"></script>
<script>
idgRequestNonPersonalizedAds = false;
console.log('## idgRequestNonPersonalizedAds', idgRequestNonPersonalizedAds);
</script>
<script>
var cookies = document.cookie.split(';');
var css = [];
for (var c = 0; c < cookies.length; c++) {
var iO = cookies[c].indexOf('=');
var n = cookies[c].substr(0, iO);
var v = cookies[c].substr(iO+1);
n = n.replace(/^\s+|\s+$/g,"");
v = v.replace(/^\s+|\s+$/g,"");
if (n == 'closedDismissables') {
dIDs = v.split(',');
for(var i = 0; i < dIDs.length; i++) {
dID = dIDs[i].replace(/^\s+|\s+$/g,"")
if (dID.length) {
css[css.length] = '#' + dID + '.dismissable';
}
}
if (css.length) {
document.write('<style type="text/css">' + css.join(', ') + '{ display:none; }</style>');
}
break;
}
}
</script>
<script>
!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{ "consentRequired": true });
permutive.addon('web', {
page: {
type: 'article',
tax: {
primaryCategories: ["azure functions"],
secondaryCategories: ["software","ruby","software development","functions","languages and runtimes","technologies","php"]
},
language: 'de',
audience: 'enterprise',
tags: ["Web Entwicklung","Productivity Software","Kreativ Software","Office Software","Collaboration"],
gTax: {"primaryIds":[283],"secondaryIds":[2,1162,241,282,260,1,1155]},
keywords: ["code","hardware","green coding","green","software","anwendung","coding","energie","entwicklung","stiller"],
description: "Code entscheidet, wie effizient die Hardware genutzt wird. Daher gibt es in der Software-Entwicklung viele Aspekte, um IT nachhaltig zu optimieren.",
ads: {
'enabled': idgStorage.adBlock,
'adblocker': idgStorage.ads
},
article: {"authors":[],"modifiedAt":"2022-02-07T04:28:00+01:00","publishedAt":"2022-02-07T04:28:00+01:00","isInsiderContent":false,"id":"3652947","type":"Online-Artikel","title":"Ob Hardware effizient genutzt wird, entscheidet der Code. So optimieren Sie ihn."}
}
});
</script>
<script async src="https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js"></script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PRTTMM2');</script>
<script type="text/javascript">
__tcfapi('addEventListener', 2, function(tcData, success) {
if ( success && (tcData.eventStatus === 'tcloaded' || tcData.eventStatus === 'useractioncomplete') ) {
if(typeof idgStorage.bcCount === 'undefined' || typeof idgStorage.bcTime === 'undefined'){
idgStorage.bcCount = 0;
idgStorage.bcTime = 0;
}
idgStorage.bcInterval = setInterval(function () {
if(typeof idgStorage.dnbData !== 'undefined'){
idgStorage.bcCount = 0;
}
if (idgStorage.bcCount === 0) {
var bcscript = document.createElement("script");
bcscript.async = true;
bcscript.type = "text/javascript";
var useSSL = "https:" == document.location.protocol;
bcscript.src = (useSSL ? "https:" : "http:") + "//cdn.blueconic.net/idg.js";
var node = document.getElementsByTagName("script")[0];
node.parentNode.insertBefore(bcscript, node);
clearInterval(idgStorage.bcInterval);
}
idgStorage.bcCount--;
}, idgStorage.bcTime);
}
});
</script>
</head>
<!-- Theme fix: clientSetting Search -->
<body class="body-root-page-17889 body-contenttype-idgarticle fp-responsive">
<!-- Theme fix: clientSetting 404 -->
<div id="mobile-menu-shadow"></div>
<div id="searchresults" style="display:none;"></div>
<div id="searchwrap" style="display:none;">
<img src="/img/onepager/cloud.svg" alt="" height="1" width="1" border="0" />
<img src="/img/onepager/security.svg" alt="" height="1" width="1" border="0" />
<img src="/img/onepager/sustainable.svg" alt="" height="1" width="1" border="0" />
<img src="/img/onepager/skilling.svg" alt="" height="1" width="1" border="0" />
<img src="/img/onepager/education.svg" alt="" height="1" width="1" border="0" />
<img src="/img/onepager/search.svg" alt="" height="1" width="1" border="0" />
<div id="searchshadow"></div>
<div id="searchclose" title="schließen"><i class="fas fa-times"></i><span>Suche schließen</span></div>
<div id="searchform">
<div class="searchformcell">
<div class="input-group">
<form action="https://microsoft.cio.de/p/suche,17890" method="GET">
<div id="loadinggif" class="nonevisible">
<img src="/img/onepager/loading-balls.svg" alt="" height="30" width="30">	
</div>
<div id="search-icon">
<i class="fas fa-search"></i>
</div>
<input id="query" name="query" class="form-control" value="" type="text" autofocus="autofocus" placeholder="Suchbegriff hier eingeben…" onfocus="this.value = this.value;">
<div class="input-group-btn">
<button type="submit" class="btn btn-danger">Jetzt suchen</button>
</div>
</form>
</div>
</div>
</div>
</div>
<div class="container idgContainerOuter" style="visibility:hidden;">
<div class="idgContainer idgContainerBordered">
<div class="idgTracking">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PRTTMM2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
idgStorage.gaData = {};
for (var i = 1; i <= 17; i++) {
idgStorage.gaData[i] = '';
}
</script>
<script>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</script>
</div>
<header class="navyHeader">
<div class="navyHeaderWrap">
<div class="hub-title">
<a href="/" class="gotocat" title="Microsoft Stories" data-menuanchor="sct-hpt">
<div title="Home" class="onepager-pics"></div>
Microsoft Stories
</a>
</div>
<div class="onepager-navig">
<ul>
<li id="homemainnavi" style="width:0px;" data-menuanchor="sct-hpt" class="active">
<a href="/" id="nvg-hpt" class="mainnavi gotocat" title="Home"></a>
</li>
<li data-menuanchor="sct-17899" class="channel-link">
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Cloud - 17899" data-ga-action-type="click" data-ga-noninteractive="false" href="/p/cloud,17899" data-number="3" data-info="Cloud" data-url="/p/cloud,17899" id="nvg-17899" class="pics17899 mainnavi gotocat" title="Cloud">
<div title="Cloud" class="onepager-pics"></div>
<span>Cloud</span>
</a>
</li>
<li data-menuanchor="sct-17900" class="channel-link">
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Sicherheit - 17900" data-ga-action-type="click" data-ga-noninteractive="false" href="/p/sicherheit,17900" data-number="4" data-info="Sicherheit" data-url="/p/sicherheit,17900" id="nvg-17900" class="pics17900 mainnavi gotocat" title="Sicherheit">
<div title="Sicherheit" class="onepager-pics"></div>
<span>Sicherheit</span>
</a>
</li>
<li data-menuanchor="sct-17956" class="channel-link">
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Nachhaltigkeit - 17956" data-ga-action-type="click" data-ga-noninteractive="false" href="/p/nachhaltigkeit,17956" data-number="5" data-info="Nachhaltigkeit" data-url="/p/nachhaltigkeit,17956" id="nvg-17956" class="pics17956 mainnavi gotocat" title="Nachhaltigkeit">
<div title="Nachhaltigkeit" class="onepager-pics"></div>
<span>Nachhaltigkeit</span>
</a>
</li>
<li data-menuanchor="sct-17957" class="channel-link">
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Modernes Arbeiten - 17957" data-ga-action-type="click" data-ga-noninteractive="false" href="/p/modernes-arbeiten,17957" data-number="6" data-info="Modernes Arbeiten" data-url="/p/modernes-arbeiten,17957" id="nvg-17957" class="pics17957 mainnavi gotocat" title="Modernes Arbeiten">
<div title="Modernes Arbeiten" class="onepager-pics"></div>
<span>Modernes Arbeiten</span>
</a>
</li>
<li data-menuanchor="sct-17907" class="channel-link">
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Weiterbildung - 17907" data-ga-action-type="click" data-ga-noninteractive="false" href="/p/weiterbildung,17907" data-number="7" data-info="Weiterbildung" data-url="/p/weiterbildung,17907" id="nvg-17907" class="pics17907 mainnavi gotocat" title="Weiterbildung">
<div title="Weiterbildung" class="onepager-pics"></div>
<span>Weiterbildung</span>
</a>
</li>
<li id="searchitem" >
<a data-ga-event-type="click" data-ga-event-category="Onepager Navigation" data-ga-event-label="Suche - 17890" data-ga-action-type="click" data-ga-noninteractive="false" href="javascript:void(0)" id="nvgmob-search" class="pics-search mainnavi gotocat" title="Suche" data-gotocat="fdcpage-search">
<div title="Suche" class="onepager-pics"></div>
<span>Suche</span>
</a>
</li>
</ul>
</div>
<div class="hidden-xs sponsored-logos">
<a href="https://www.microsoft.com/de-de/" target="_blank" class="sponsor main-sponsor"><img src="/img/mso/ms.svg" /></a>
<a href="https://www.cio.de" target="_blank" class="sponsor idg-sponsor-first"><img src="/img/mso/cio.svg" /></a>
<a href="https://www.computerwoche.de" target="_blank" class="sponsor idg-sponsor-second"><img src="/img/mso/cw.svg" /></a>
</div>
<div id="burger-toggle" class="burger-menu hidden">
<i class="fa fa-bars"></i>
</div>
</div>
<div class="visible-xs sponsored-logos">
<a href="https://www.microsoft.com/de-de/" target="_blank" class="sponsor main-sponsor"><img src="/img/mso/ms.svg" /></a>
<a href="https://www.cio.de" target="_blank" class="sponsor idg-sponsor-first"><img src="/img/mso/cio.svg" /></a>
<a href="https://www.computerwoche.de" target="_blank" class="sponsor idg-sponsor-second"><img src="/img/mso/cw.svg" /></a>
</div>
</header>
<div class="idgContentWrapper">
<script type="text/javascript">
if (typeof(idgStorage) !== 'undefined') {
idgStorage.articleTitle = 'Ob Hardware effizient genutzt wird, entscheidet der Code. So optimieren Sie ihn.';
}
</script>
<article class="idgArticleDetail"><div class="row"><div class="col-xs-12"><div class="article-background-image" style="background-image: url('//images.computerwoche.de/bdb/3351413/original.png');"></div><div id="article" class="fullpage-wrapper"><div class="article-navigator-left"><a class="article-back-button" href="#"><div class="arrow-left-wrapper"><i class="fa fa-chevron-left hvr-forward" aria-hidden="true"></i></div></a></div><div id="article-head" class="section article-first-section active"><div class="article-section-bg-image"><div class="article-head-wrapper"><div class="article-head"><h2>5 Ansätze für Green Coding</h2><h1>Ob Hardware effizient genutzt wird, entscheidet der Code. So optimieren Sie ihn.</h1><div class="social-share-list-text"><span>Artikel teilen:</span></div><div class="social-share-list"><span class="social-icon"><a title="Facebook" href="https://www.facebook.com/sharer.php?u=https://microsoft.cio.de/3652947&amp;t=5%20Ans%C3%A4tze%20f%C3%BCr%20Green%20Coding%3A%20Ob%20Hardware%20effizient%20genutzt%20wird%2C%20entscheidet%20der%20Code%2E%20So%20optimieren%20Sie%20ihn%2E" target="_blank" rel="noopener" class="onepager-social-tracking" data-network="Facebook" data-action="Share" data-category="Social Tracking Top" data-label="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947"><i class="fab fa-facebook-f"><!--Facebook--></i></a></span><span class="social-icon"><a title="Twitter" href="https://twitter.com/share?url=https://microsoft.cio.de/3652947&amp;text=5%20Ans%C3%A4tze%20f%C3%BCr%20Green%20Coding%3A%20Ob%20Hardware%20effizient%20genutzt%20wird%2C%20entscheidet%20der%20Code%2E%20So%20optimieren%20Sie%20ihn%2E" target="_blank" rel="noopener" class="onepager-social-tracking" data-network="Twitter" data-action="Tweet" data-category="Social Tracking Top" data-label="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947"><i class="fab fa-twitter"><!--Twitter--></i></a></span><span class="social-icon"><a title="LinkedIn" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://microsoft.cio.de/3652947&amp;title=5%20Ans%C3%A4tze%20f%C3%BCr%20Green%20Coding%3A%20Ob%20Hardware%20effizient%20genutzt%20wird%2C%20entscheidet%20der%20Code%2E%20So%20optimieren%20Sie%20ihn%2E" target="_blank" rel="noopener" class="onepager-social-tracking" data-network="LinkedIn" data-action="Share" data-category="Social Tracking Top" data-label="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947"><i class="fab fa-linkedin-in"><!--LinkedIn--></i></a></span><span class="social-icon"><a title="Xing" href="https://www.xing.com/app/user?op=share&amp;url=https://microsoft.cio.de/3652947;title=5%20Ans%C3%A4tze%20f%C3%BCr%20Green%20Coding%3A%20Ob%20Hardware%20effizient%20genutzt%20wird%2C%20entscheidet%20der%20Code%2E%20So%20optimieren%20Sie%20ihn%2E" target="_blank" rel="noopener" class="onepager-social-tracking" data-network="XING" data-action="Share" data-category="Social Tracking Top" data-label="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947"><i class="fab fa-xing"><!--Xing--></i></a></span></div></div></div><div class="chevron-bottom-wrapper"><span class="article-down-btn"><i class="fa fa-chevron-down" aria-hidden="true"></i></span></div></div></div><div id="article-content" class="section article-second-section"><div class="article-body articlebody idgGalleryWidthHelper"><div><p>Immer mehr Firmen überprüfen die ökologischen Folgen ihres Tuns – an allen Stellen ihrer Organisation sowie innerhalb der Lieferkette. Eine wichtige Rolle spielt dabei die IT. Der Kohlenstoff-Fußabdruck aller global genutzten Geräte, des Internets und der sie unterstützenden Systeme ist für etwa 3,7 Prozent der weltweiten Treibhausgasemissionen verantwortlich. Ebenso viel verursacht die Luftfahrtindustrie weltweit. So der Lean-ICT-Report, den der französische Think Tank „The Shift Project“ 2019 veröffentlicht hat. </p><p>Geht es um Nachhaltigkeit in der IT, wird aber Software-Entwicklung bislang außer Acht gelassen. Dabei ist sie dafür verantwortlich, wie die Hardware eingesetzt – und wie effizient sie genutzt wird. Je mehr Hardware leisten muss, umso mehr Energie verbraucht sie und der CO2-Ausstoß steigt. Das gilt für Computer am heimischen Schreibtisch und am Arbeitsplatz ebenso wie für die Geräte, welche Datenpakete durchs Netzwerk schicken. </p><p>Jeder Software-Code hat also einen ökologischen Fußabdruck. Doch das Potenzial von Green Coding – also auf Nachhaltigkeit angelegtes Programmieren – wird bisher kaum genutzt. </p><div class="clearfix"><!--clear--></div><h3 id="header_EL_subheadingN1001D">Toter Code verbraucht unnötig Ressourcen</h3><p>Dabei machen die Entwickler häufig schon vieles richtig, sagt Torsten Stiller, Developer Lead Azure Business Group bei Microsoft und Experte für Softwareentwicklung: „Viele achten zum Beispiel auf Effizienz, um Kosten zu sparen. Oder sie schreiben eleganten Code, um innovative Technologien einsetzen zu können.“</p><p> Doch will man Nachhaltigkeit vorantreiben, funktioniert das nur, wenn man das bewusst tut und nicht als Seiteneffekt, erläutert Stiller: „Es geht darum, sich stets auf das konkrete Ziel der Programmierung zu konzentrieren und grundsätzlich zu überlegen, wie sich dieses mit dem geringsten Ressourcenverbrauch erreichen lässt.“ So sollten sich Entwickler schon bei der Planung und beim Schreiben des Codes Gedanken über die ökologischen Auswirkungen machen. </p><p>Die Punkte, an denen man ansetzen kann, lassen sich fünf Bereichen zuordnen. </p><p><strong>(1) Unnötige Berechnungen vermeiden</strong><br>Mithilfe von Code-Coverage-Messungen lässt sich schon frühzeitig feststellen, wie viel Code wirklich ausgeführt wird. Unterschreitet dies einen bestimmte Prozentsatz, sollte der Entwickler noch einmal neu ansetzen. „Sonst produziert man toten Code“, so Stiller. „Und toter Code belegt zum Beispiel unnötig Speicher und erhöht mitunter die Komplexität.“ </p><p><strong>(2) Komplexität verringern</strong> <br>Grundsätzlich sollte man darauf achten, Code „möglichst sauber zu schreiben“, wie Stiller betont. Dadurch hätten anderen Entwickler die Möglichkeit, den Code ebenfalls zu nutzen oder ihn leichter umzubauen. Das verhindert, dass Code neu geschrieben werden muss, was wiederum Ressourcen verbraucht. </p><p><strong>(3) Anwendungen modular aufbauen </strong><br>Bei dem Konzept der Microservices lassen sich zum Beispiel Module oder Services unabhängig voneinander hoch- und runterskalieren. Werden Anwendungsteile zeitweise wenig intensiv genutzt, können sie unabhängig von anderen Teilen die Hardware freigeben, die sie zuvor genutzt hatten. Die Last wird dann auf weniger Compute-Einheiten verteilt. Services lassen sich also automatisch herunter- und bei Bedarf wieder hochfahren. Das fördert einen effizienteren Betrieb der Anwendung. Dagegen muss eine monolithisch aufgebaute Software komplett hochgefahren werden – inklusive von Services, die gar nicht genutzt werden.</p><p><strong>(4) Zusammenarbeit von Entwicklung und Betrieb optimieren </strong><br>Ein weiterer Bereich, der beim Green Coding eine wichtige Rolle spielt, sind die Methoden, wie Software geplant und kollaborativ erstellt wird. Ganz wichtig dabei ist DevOps – also die optimierte Zusammenarbeit von Entwicklung und IT-Betrieb. Das stellt sicher, dass die kommenden Anwendungen auch wirklich für den anvisierten Zweck passen. „Grundsätzlich sollte man so agil wie möglich auf Anforderungen reagieren können, die sich ständig ändern. Um nicht etwas zu entwickeln, was am Ende des Tages wieder toten Code und unnötige Aufwände generiert“, sagt Stiller. </p><p><strong>(5) Open Source nutzen </strong><br>Außerdem hält er es für wichtig, beim Thema Nachhaltigkeit auch auf Open Source zu setzen. Quelloffene Software kann von anderen genutzt und weiterentwickelt werden. So lässt sich verhindern, dass das Rad jedes Mal neu erfunden beziehungsweise eigentlich vorhandener Code wieder neu geschrieben werden muss. Entwickler sollten dabei jedoch darauf achten, Redundanzen zu vermeiden, so Stiller. Will heißen: Der verwendete Open-Source-Code kann Abschnitte enthalten, die für die individuelle Anwendung nicht notwendig sind, bei der Ausführung aber Ressourcen verbrauchen. </p><div class="clearfix"><!--clear--></div><h3 id="header_EL_subheadingN10083">Auch die Wahl der Plattform spielt eine Rolle </h3><p>Wo wird die Software schließlich bereitgestellt? Die Cloud bietet hier aus Energieeffizienz-Perspektive klare Vorteile. Die großen Cloud-Provider können ihre Infrastruktur in der Regel unter günstigeren Bedingungen betreiben als Anwenderunternehmen. So setzen sie etwa auf Technologien, die weniger Energie verbrauchen. Und Cloud-Provider wie zum Beispiel Microsoft achten darauf, die eigenen Rechenzentren mit erneuerbaren Energien zu betreiben. </p>
</div>
</div>
<div class="understitial-wrapper">
<div class="understitial-background-image" style="background-image: url('//images.computerwoche.de/bdb/3351412/original.jpg')"></div>
<div class="understitial-content-wrapper">
<div class="understitial-type">
<i class="fab fa-microsoft microsoft"></i>
<span>E-Book</span>
</div>
<h4>
<a href="https://info.microsoft.com/DE-SUSTN-CNTNT-FY22-09Sep-02-Digitalisierung-fur-eine-nachhaltige-Zukunft-SRGCM4957_LP01-Registration---Form-in-Body.html" 
data-category="Understitial" 
data-action="Click" 
data-label="https://info.microsoft.com/DE-SUSTN-CNTNT-FY22-09Sep-02-Digitalisierung-fur-eine-nachhaltige-Zukunft-SRGCM4957_LP01-Registration---Form-in-Body.html" 
target="_blank" class="onepager-tracking">
IT als Schlüssel für Nachhaltigkeit
</a>
</h4>
<p>
Lernen Sie Beispiele kennen f&uuml;r erfolgreiche Digitalisierungs- und Nachhaltigkeitsinitiativen bei Microsoft, Kunden und Partnern.&nbsp;
</p>
<button>
<a href="https://info.microsoft.com/DE-SUSTN-CNTNT-FY22-09Sep-02-Digitalisierung-fur-eine-nachhaltige-Zukunft-SRGCM4957_LP01-Registration---Form-in-Body.html" 
data-category="Understitial" 
data-action="Click" 
data-label="https://info.microsoft.com/DE-SUSTN-CNTNT-FY22-09Sep-02-Digitalisierung-fur-eine-nachhaltige-Zukunft-SRGCM4957_LP01-Registration---Form-in-Body.html" 
target="_blank" class="onepager-tracking">
Hier Impulse holen
</a>
</button>
</div>
</div>
<div class="article-body articlebody idgGalleryWidthHelper">
<div>
<p>Teilen sich zudem viele Anwender die gleichen Rechen-Ressourcen in einer Public Cloud, ist der Betrieb von IT effizienter. Das ist vergleichbar mit dem Car Sharing, das ökologisch sinnvoller ist ein eigenes Auto zu besitzen, das 80 Prozent der Zeit auf dem Parkplatz steht. </p><div class="clearfix"><!--clear--></div><h3 id="header_EL_subheadingN100A3">Bewusstsein für Green Code schärfen </h3><p>All diese Methoden sind bekannt und werden auch angewandt. Aber es gibt noch reichlich Potential, glaubt Stiller. Daher steht für ihn an erster Stelle, ein entsprechendes Bewusstsein zu schaffen. „Im Privatleben achtet man mittlerweile oft auf Nachhaltigkeit“, so Stiller. „Mein Frau fährt zum Beispiel ein E-Auto, wir kaufen regionale und saisonale Lebensmittel und vermeiden Plastiktüten. Und genauso geht es auch in der Softwareentwicklung darum, eine entsprechende Denke zu verinnerlichen.“ </p><p>Um das Thema weiter voranzubringen, hat Microsoft mit weiteren IT-Unternehmen wie Accenture, GitHub und ThoughtWorks sowie der Linux Foundation die Initiative „<a href="https://greensoftware.foundation/" title="The Green Software Foundation" target="_blank" rel="nofollow noopener" class="onepager-tracking" data-category="Artikel-Link" data-action="Click" data-label="https://greensoftware.foundation/">The Green Software Foundation</a>“ ins Leben gerufen. Ziel ist es, <a href="https://blogs.microsoft.com/blog/2021/05/25/accenture-github-microsoft-and-thoughtworks-launch-the-green-software-foundation-with-the-linux-foundation-to-put-sustainability-at-the-core-of-software-engineering/" title="ein Ökosystem für die Entwicklung grüner Software aufzubauen" target="_blank" rel="nofollow noopener" class="onepager-tracking" data-category="Artikel-Link" data-action="Click" data-label="https://blogs.microsoft.com/blog/2021/05/25/accenture-github-microsoft-and-thoughtworks-launch-the-green-software-foundation-with-the-linux-foundation-to-put-sustainability-at-the-core-of-software-engineering/">ein Ökosystem für die Entwicklung grüner Software aufzubauen</a>, das Organisationen verbindet sowie Standards, Werkzeuge und Best Practices liefert. Damit könnte dann auch Green Coding so selbstverständlich werden wie der Verzicht von Plastiktüten im Supermarkt. </p><p>Eine weitere Lösung von Microsoft ist das Emissions Impact Dashboard. Nutzen Sie Dienste aus der Microsoft-Cloud, behalten Sie mit dem Dashboard die CO2-Emissionen ihrer Dienste im Blick. </p><p><a class="onepager-tracking btn btn-danger" rel=" noopener" href="https://www.microsoft.com/de-de/sustainability/emissions-impact-dashboard?activetab=pivot_2:primaryr12" target="_blank" data-category="Artikel-Button" data-action="Click" data-label="https://www.microsoft.com/de-de/sustainability/emissions-impact-dashboard?activetab=pivot_2:primaryr12">Jetzt Auswirkungen senken</a></p><div class="clearfix"><!--clear--></div></div><div class="article-end-social-media"><div class="social-share-list-text"><span>Artikel teilen:</span></div><div class="social-share-list"><span class="social-icon"><a title="Facebook" href="https://www.facebook.com/sharer.php?u=https://microsoft.cio.de/3652947&amp;t=5%20Ans%C3%A4tze%20f%C3%BCr%20Green%20Coding%3A%20Ob%20Hardware%20effizient%20genutzt%20wird%2C%20entscheidet%20der%20Code%2E%20So%20optimieren%20Sie%20ihn%2E" target="_blank" rel="noopener" class="tracksocial onepager-tracking" data-network="Facebook" data-action="Share" data-category="Social Tracking Bottom" data-label="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947"><i class="fab fa-facebook-f"><!--Facebook--></i></a></span><span class="social-icon"><a title="Twitter" href="https://twitter.com/share?url=https://microsoft.cio.de/3652947&amp;text=5%20Ans%C3%A4tze%20f%C3%BCr%20Green%20Coding%3A%20Ob%20Hardware%20effizient%20genutzt%20wird%2C%20entscheidet%20der%20Code%2E%20So%20optimieren%20Sie%20ihn%2E" target="_blank" rel="noopener" class="tracksocial onepager-tracking" data-network="Twitter" data-action="Tweet" data-category="Social Tracking Bottom" data-label="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947"><i class="fab fa-twitter"><!--Twitter--></i></a></span><span class="social-icon"><a title="LinkedIn" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://microsoft.cio.de/3652947&amp;title=5%20Ans%C3%A4tze%20f%C3%BCr%20Green%20Coding%3A%20Ob%20Hardware%20effizient%20genutzt%20wird%2C%20entscheidet%20der%20Code%2E%20So%20optimieren%20Sie%20ihn%2E" target="_blank" rel="noopener" class="tracksocial onepager-tracking" data-network="LinkedIn" data-action="Share" data-category="Social Tracking Bottom" data-label="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947"><i class="fab fa-linkedin-in"><!--LinkedIn--></i></a></span><span class="social-icon"><a title="Xing" href="https://www.xing.com/app/user?op=share&amp;url=https://microsoft.cio.de/3652947;title=5%20Ans%C3%A4tze%20f%C3%BCr%20Green%20Coding%3A%20Ob%20Hardware%20effizient%20genutzt%20wird%2C%20entscheidet%20der%20Code%2E%20So%20optimieren%20Sie%20ihn%2E" target="_blank" rel="noopener" class="tracksocial onepager-tracking" data-network="XING" data-action="Share" data-category="Social Tracking Bottom" data-label="https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947"><i class="fab fa-xing"><!--Xing--></i></a></span></div></div></div><div class="article-end-next-article"><div class="articlenext-text-wrapper"><a href="/a/hypervernetzte-unternehmen-teilen-das-wissen-ueber-kunden-ueberall-und-jederzeit,3652946" rel="nofollow" id="npnext" class="onepager-tracking" title="Nächster Artikel" data-category="Nächster-Artikel" data-action="Click" data-label="/a/hypervernetzte-unternehmen-teilen-das-wissen-ueber-kunden-ueberall-und-jederzeit,3652946"><h2>Nächster Artikel: Hypervernetzte Unternehmen teilen das Wissen über Kunden überall. Und jederzeit.</h2><span class="animated-arrow"><i class="fa fa-chevron-down" aria-hidden="true"></i></span></a></div></div><div class="article-end-recommendation"></div></div><div class="article-footer"><ul class="list-inline"><li><a href="https://www.computerwoche.de/p/datenschutz,265" title="Datenschutz" target="_blank">Datenschutz</a></li><li><a href="https://www.computerwoche.de/p/cookie-policy,17707" title="Cookie Policy" target="_blank">Cookie Policy</a></li><li><a href="https://www.computerwoche.de/p/impressum,3716" title="Impressum" target="_blank">Impressum</a></li><li><span>© IDG Tech Media GmbH</span></li></ul></div></div></div></div></article>
<script type="application/ld+json" id="articleJson">
{"dateModified":"2022-02-07T16:28:00Z","publisher":{"@type":"Organization","logo":{"height":57,"@type":"ImageObject","url":"https://microsoft.cio.de/includes/images/amp/logo/Microsoft.png","width":182},"name":"Microsoft"},"datePublished":"2022-02-07T16:28:00Z","@context":"http://schema.org","@type":"NewsArticle","headline":"Ob Hardware effizient genutzt wird, entscheidet der Code. So optimieren Sie ihn.","image":{"height":675,"@type":"ImageObject","url":"https://images.computerwoche.de/bdb/3351413/1200x.jpg","width":1200},"mainEntityOfPage":{"@type":"WebPage","@id":"https://microsoft.cio.de/a/ob-hardware-effizient-genutzt-wird-entscheidet-der-code-so-optimieren-sie-ihn,3652947"},"author":{"@type":"Organization","name":"Microsoft"},"description":"Code entscheidet, wie effizient die Hardware genutzt wird. Daher gibt es in der Software-Entwicklung viele Aspekte, um IT nachhaltig zu optimieren."}
</script>
<div class="modal fade" id="modalArticleShareEMail">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
<h4 class="modal-title">Per E-Mail versenden</h4>
</div>
<div class="modal-body">&nbsp;</div>
<div class="modal-footer">
<button type="button" class="btn btn-default" data-dismiss="modal">Schließen</button>
<button type="button" class="btn btn-danger" onclick="$('#modalArticleShareEMail form').submit()">Senden</button>
</div>
</div>
</div>
</div>
<div class="modal fade" id="modalArticlePdfDownload">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
<h4 class="modal-title">Artikel als PDF downloaden</h4>
</div>
<div class="modal-body">&nbsp;</div>
</div>
</div>
</div>
<div class="modal hide fade idgModalMedia in" id="modalArticleAuthor">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal">×</button>
<h3>&Uuml;ber den Autor</h3>
</div>
<div class="modal-body">
&nbsp;
</div>
<div class="modal-footer">
<a href="#" class="btn btn-close" data-dismiss="modal">Schlie&szlig;en</a>
</div>
</div>
</div>
</div>
</div>
<script src="https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js"></script>
<script>
WebFont.load({
custom: {
families: [
'Open Sans:400,700',
'Open Sans Condensed:300,700',
],
urls: [
'https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700|Open+Sans+Condensed%3A300%2C700&display=swap'
]
}
});
</script>
<script src="/includes/compiled/001_core.min.js?v=202202061158"></script>
<script src="/includes/compiled/010_themes.onepager.min.js?v=202202061158"></script>
<script src="/includes/compiled/015_clients.mso.min.js?v=202202061158"></script>
<!--
page info section .......................................................
page: 17956
host: microsoft.cio.de
environment: aws
client: mso
cache: false
date: 08.02.2022 20:07:32
execution time: 2.996
-->
<script>
if (typeof console == 'object') {
console.log('page: 17956');
console.log('host: microsoft.cio.de');
console.log('environment: aws');
console.log('client: mso');
console.log('cache: false');
console.log('date: 08.02.2022 20:07:32');
console.log('execution time: 2.996');
}
</script>
<!-- LinkedIn universal website tag code -->
<script type="text/javascript">
_linkedin_partner_id = "182497";
window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
window._linkedin_data_partner_ids.push(_linkedin_partner_id);
</script>
<script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://px.ads.linkedin.com/collect/?pid=182497&fmt=gif" />
</noscript>
<!-- End LinkedIn universal website tag code -->
<!-- Twitter universal website tag code -->
<script>
!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js',
a=t.getElementsByTagName(n)[0],a.parentNode.insertBefore(u,a))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','nuutp');
twq('track','PageView');
</script>
<!-- End Twitter universal website tag code -->
<!-- Facebook universal website tag code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window, document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1600850676776682');
fbq('track', 'PageView');
</script>
<noscript>
<img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1600850676776682&ev=PageView&noscript=1"/>
</noscript>
<!-- End Facebook universal website tag code -->
</body>
<!--
article info section ....................................................
article: 3652947
date: 08.02.2022 20:07:32
modification date: 07.02.2022 17:36:05
-->
</html>
